nnal @ dabitraining.com

Q +91 63011 70782

VINAY TECH HOUSE
Azure Bl (Azure Data Engineer)

c% Trainer: Mr. Pavan [9+ years of IT Exp, 4+ in Azure]

@ Duration: 45-50 hours, Daily 1 hour

':E Modes: Normal / Fast Track / One on One

Fee: (Normal track) 14,000/-

Institute Provides

e In-Depth Theory & practical Material e Daily Live Class Videos Shared
e Complete Practical Oriented Training e Good Interaction with the Trainers
e Mock Interviews e Resume Preparation Sessions
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TOPIC 1: Azure Accounts Subscription

>Free Account
»Student Account
>Pay As You Go
»Creation of Accounts

___________\
N oenen -

TOPIC 2: Azure Resource Group, Resources & Services

_______________________________________________________________________________________________

>How to Create Resources and Resource Groups in Microsoft Azure
>Azure Resource Manager vs. classic deployment
>Azure to Manage or Delete Resource Group and Resource

-

TOPIC 3: Azure Pricing and Report

>Azure Subscription Maintenance
>Planning and Managing Cost
>Azure Support Option

>Azure Service Level Agreement
>Azure Cost Analysis and Restriction
>Azure Cost billing Report

________________.,.
N

TOPIC &: Azure Storage account

A. Blob

B. File Shares

C. Table

D. Ques

>Storage Service & Account

>Creating a Storage Account

»Standard & Premium Performance

>Understanding Replication

>Hot, Cold & Archive Access Tiers

>Working with Containers & Blobs

>Types of Blobs: Block Blobs, Append Blobs, Page Blobs
>Blob Metadata

>Soft Delete

»>Azure Storage Explorer

>Access Blob Securely

> Access Key

>Account Shared Access Token

>Service Shared Access Token >Storage Service Encryption
>Shared Acess Policy >Azure Key Vault

T
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TOPIC 5: Azure SQL

_______________________________________________________________________________________________

>Azure SQL Topics

»Azure SQL Server

»Azure SQL Data Base

>Azure SQL Managed Instance
»>Azure SQL IN Virtual Machine
>Introduction to Azure SQL Database
>Comparing Single Database
>Manged Instance

>Creating and Using SQL Server
>Azure SQL Database Tools
>Migrating on Premise Database to SQL Azure
>Purchasing Models

>DTU Service Tiers

»vCore Based Model

>Serverless Computer Tier

>Service Tiers
- General Purpose / Standard

- Business Critical / Premium

- Hyperscale
»>Deployment of an Aure SQL Database
> Elastic Pools
>What is SQL Elastic Pools

Choosing the Correct Pool Size
>Creating a New Pool
>»Manage Pools
>Monitoring and Tuning Azure SQL Database
> Configure SQL Database Auditing
>Export and Import of Database
>Automated backup
>Point in Time Restore
>Restore Deleted Databases
>Long-Term Backup retention
>Active Geo Replication
»Auto Failover Group

______________________________________________________________________________________________

»Azure Data Lake Store
-Azure Data Lake Gen1
-Azure Data Lake Gen2
>Azure Data Lake Analytics
>Introduction to Azure Data lake
>What is Data lake
>What is Azure Data lake

___________________\
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>Explore Data Lake Store

e e e e e s e S O i i, e i e . e s e i e e, e i i i e s e e s s

. >Data Lake Architecture? >Uploading Sample File E
. >Working with Azure Data lake >Using Azure Portal |
. >Provisioning Azure Data lake >Using Storage Explorer l
i >Explore Data Lake Analytics >Using Azure CLI |

TOPIC 7: Azure Data Lake Analytics

>Creation of Azure Data Lake Analytics Using Data Lake Gen'
>U-SQL Code Job Submitting

>Working with Sample Data and Scripts

>Use of Analytics Units (AU's)

»Heat Map

>Job Graph

>Running USQL Analytics Query from Azure Data Factory
>Automation USQL Script using Trigger in ADF.

_____________________\
- - - - - -

¥’
.

»Creating the Synapse DWH DB

>Dedicated SQL pools (formerly SQL DW)

>»Managing and Loading the Data in DWH Objects
>Loading the data in DWH using ADF from different source.

TOPIC 9: Azure Polybase

>Creating Master Key
>Creating Scoped Credential
>Creating External Data Source
>Creating External File Format
> Creating External Table

o
- —————————— -

TOPIC 10: Azure Analysis Services (SSAS-MSBI)

Ml S e s S e e e e e e el e S e e S e sl i s e s —— ——

>Creating an Analysis Project Using Visual Studio
>Workspace Database, Server, Direct Query, Backup to Disk
>Installation steps, Error Mechanisms

>Creating a Tabular model and Setting

>Data to the Model

" T " " . 2.
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>Renaming tables

> filtering columns
>Rename Columns

> Monitoring relationships
> Providing relationships
> Create Hierarchies

> Create Partitions

> Create Perspectives

> Create Roles
»Create KPIs
> Deployment

o . — —————————_————— T T T ]

>»M How to create Virtual Machine E
>M Managing Directories !
>K Accessing the RDP from On-premises i
>M Direct Connecting to Remote Desktop through Public IP [
>M Different Operating System Configuration. i
>® Managing and Reset the VM Password. :

I

>® Introduction about SSIS Tool

>W Installation Visual Studio SSDT different version for SSIS ETL

> Creating New Project and Modifying the exciting SSIS ETL Project

>M Creating different type of Packages

>W Control Flow and its different type of Tasks

»>M Data Flow Task and its different type of components and Transformation

>[ Different Source and Destination for data loading

> Full Load development using SSIS Package

>R Incremental Process using Lookup Transformation, SCD and CDC components
>M Automation or scheduling the exiting SSIS ETL Packages for daily load

>l SSIS Package Deployment model using Ispac file and Manifestfiles

>N Project Deployment model, Package Deployment and File System model fo SSIS ETL Packages
> Creating Jobs to schedule the exiting SSIS ETL Packages and configurations

TOPIC 13: SSIS Different Deployment Methods

>W SSIS Package Deployment model using Ispac, File Syetem and Manifestfiles
>M Project Deployment model, Package Deployment and File System model fo SSIS ETL Packages
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TOPIC 14: Azure data Factory ADF ETL

Azure Data Factory vs SSIS

>Linked Services

»Data Sets

>Pipelines

>Parameters

>Variables

>Copy Data

»>Monitor Manage

>Autor and Deploy

>Different kinds of integration runtimes
>How to create pipelines from template
>How to configure different Integration Runtimes
>Azure Integration runtime

>Azure Self Hosted Integration Runtime
>SSIS Integration runtime

Move & Transform

>Copy Data
>Data Flow

General Activities

>Append Variable

> Execute Pipeline
>Execute SSIS Package
> Get Metadata
>Lookup

»Stored procedure
>Set Variable

>Delete

>Wait

> Until

>WEB

>Precedence Constraints
>Breakpoint

>Data Flow

Iteration & Conditionals

> Filter
»For Each
»If Condition

Integration Runtime

>Azure Integration Services Runtime (Auto Resolved)
>SSIS Integration Services Runtime (Lift & Shift Operation)
>Self-Hosted Integration Runtime (Extract data from external Sources)

T T " " . 2.
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Data Flow Transformation

>Append Variable
>Source

>Sink

>Filter

>Select

> Conditional Split
>Derived Column
>Join

>Lookup

>Union
>Aggregate

> Exists
>Surrogate key

> Pivot

>Un Pivot

>Sort

>Alter Row

Different Type of Loading Process in ADF
>Incremental Load using SCD (Insert Update operation) and Lookups Transformation :l
>Full Load operation for Dimension and Master data i

>Delta Load Process for Daily load with latest date data
>Regular or Daily Load

ADF ETL Pipeline Deployments:-

>What are ARM Templates and how to Export and Import?

>How to Deploy Data Factory Pipelines DEV, Test, Prod environment

>How to Create a Git Hub Account

>How to work with Repository, Branch, Pull Request, Push Request Merge Code?
>Code Repository in Git Hub for CICD deployments

>Scheduling Automation ADF ETL Pipeline Using

* Triggers & Monitor: -

>+ What is Trigger and its type?

>+ Normal Schedule Trigger

>+ Event-Based Trigger

>+ Tumbling Window

>+ Logic App to Schedule Mail Alters and ADF Pipeline
>+ Debugging and Monitoring Pipelines

>+ Error handling and Logging error records

>+ Lift and Shift SSIS packages into Azure Data Factory

T T " " . 2.
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Case Study | Practice on Azure ADF ETL: -

>Moving data from Blob to Blob

>Moving data from Blob to Azure SQL Server

>Moving data from SQL Server to Blob

>Moving data from ADLS to Azure SQL Server

>Moving data from ADLS to ADLS (Gen1 & Gen2)

> Configure different Types of Integration Runtimes

»Azure Integration runtime

>Azure Self Hosted Integration Runtime

>SSIS Integration runtime for Lift & Shift operation

>Moving Data from Blob to On Premise SQL Server

>Moving Data from On Premise SQL Server To Azure SQL

>Moving Data from On Premise files to Azure SQL Server

>Moving Data from On Premise files to ADLS and to Azure SQL Server

>Load data from Multiple tables into SQL Server using dynamic expressions & schema

>Creation scripts

>Load data from Multiple Files with SQL Server dynamic expressions & schema creation

>Script

>Implementing and auditing logs for developed package to track the detail about
ADF ETL Pipelines.

>Mail Alter configuration in ADF ETL pipeline.

>Stored procedure inputs and outputs parameters configuration to load the data

>Use dynamic parameters within the pipeline

>Trigger a pipeline using another pipeline

> Different ways to deploy Azure resources from one resource group to another
resource group

> Deploy SSIS packages to ADF and Schedule

>Query Azure Data Lake using U-SQL activity and running the same ADF pipeline

>Loading the data into Azure DWH Synapse from multiple sources

]

> Configure Databricks ‘I
> Creating the Account using Azure and Data Brick Community Edition i
> Creating and Configuring Clusters and types. I
> Create Notebooks in different platform (Python, Scala, R, Spark SQL f
»Working with Notebook & Libraries Options |
>Scheduling the Notebook. [
>Working with Data Brick File System and Notebooks {
> Data Movement\Loading Using Blob, DWH Synapse and other Storages. [
>Filler the Data and Modification l
> Assign the Cluster based on requirement to the Notebook. :t

e e e ——————

______________________________________________________________________________________________
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TOPIC 16: Azure Active Directory

- T . -,

>Role \ User Creation
>Working with App Registration for Access Key
>Permission

e e i I R S T R T R S R T e S R T T T T A S e e e e e e T A R T S T R S S e e e S S S i e i
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' >What is Azure Event Grid Event Hub !

. >How to configure Event and Hub |

' >Perform Realtime analytics on Event Hub Data :

i > Useful of Grids in Azure Data Factory for Storage Triggers E
TOPIC 18: Azure Live Streaming Analytics

i »Data Loading Process and Data Movement ':
TOPIC 19: Azure Logic Apps

i > Configuring and Sending Mail Alerts Using Templets &

' »Scheduling the Resource or ADF using it. E

e e —

~

>Creating the Account

»Managing the Master and Main Brach

> Creation of Local Branch and code merging
»Working with Merging and Pull Request

> Deployment and Code Merging.

e i s i ) S e i Ul M i . Bt i i i o Gl S il i et . e i M el N s i i s . B it i N i i i e i il
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TOPIC 21: Azure Migration

- ———————— -

>Migration On-Premises data to Azure cloud
> Working on BACKUP and DACPACK file to move data to Azure Storages
> Data Migration using Azure Migration Assessment Tool

________..‘
"
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>What is Power Bl
>What is Power Bl Service > Publish Reports into power Bl cloud services
>How to create Reports in Power Bl desktop Using Azure Data sources

e e e e e e e e et ot e et e S e e B e et S Tt ol St e
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